1.1 Felixの変更点

バージョン1.4.5の変更点(2009/03/17 リリース)

Felixバージョン1.4.5では、新機能の追加や不具合の改善、性能の向上などが行われています。

Felix

  • 【不具合の改善】数字の自動置換え機能に不具合がありました。
  • 【不具合の改善】用語のあいまい検索を使用するとき、一致が表示されない場合がありました。
  • 【不具合の改善】一致がない場合に照会を編集すると、エラーが出ました。
  • 【不具合の改善】完全一致のとき、訳文の修正ができませんでした。
  • ユーザ設定の取り込み・保存ができるようになりました。(「ツール」メニューから「ユーザ設定の取り込み・保存」を選択)
  • XMLファイルの処理が改善されました。
  • サーバーに存在するメモリ・グロサリ(用語集)が「最近使ったアイテム」のリストに載らないようになりました。
  • 倍率調整のメニュー項目が追加されました。
  • UIやメッセージの改善。
  • TMX書き出しの改善。

Wordインターフェース

  • 【不具合の改善】<、>という文字があると、文章が途中で切れる場合がありました。
  • 【不具合の改善】特定の書式では、エラーが発生する場合がありました。
  • 【不具合の改善】括弧のある文章では、エラーが発生する場合がありました。
  • 【不具合の改善】複数の文書を連続して開くと、エラーが発生する場合がありました。
  • 「翻訳歴」の機能が有効になっていない場合、そのコンポーネントが取り込まれません。
  • 動作が安定になるための改善。

Excelインターフェース

  • CTRL + ALT + F9 を押すと、キーボード・ショートカットが有効・無効に切り替わります。

PowerPointインターフェース

  • 【不具合の改善】小数点記号をピリオドと誤認する場合がありました。
  • CTRL + ALT + F9 を押すと、キーボード・ショートカットが有効・無効に切り替わります。

バージョン1.4.3の変更点(2009/01/15 リリース)

Felixバージョン1.4.3では、ユーザの要求があった機能が追加されたり、不具合の改善が行われたりしています。

Felix

  • 【不具合の改善】マッチを編集した後、マッチの文字がダブル場合がありました。
  • 【不具合の改善】校正モードでは、用語の登録機能が利用できませんでした。
  • ユーザ名が設定可能に成りました。
  • TMのエントリ(翻訳単位:TU)に、「作成者」と「変更者」フィールドが追加されました。
  • 訳文を登録した直後、再度訳文を登録すると新規登録ではなく、現在の訳文が訂正されるようになりました。
  • Felixのテンプレート(ひながた)エンジンでは、ループ機能ができました。詳細は、付録B:のテンプレート(ひながた)エンジンを参照してください。
  • ほとんどのデータ表示では、ひながたがあります。
  • 【不具合の改善】メモリ管理・グロサリ管理のダイアログから、.ftm、.fgloss形式のファイルを開く事ができるように成りました。
  • 【不具合の改善】パワーポイントやエクセルがインストールされていない場合、Fellxアンインストール時にエラーが出ていました。
  • 【不具合の改善】グロサリ(用語修)画面から、「名前を付けて保存」しても、.fgloss形式でしか保存できませんでした。
  • 【不具合の改善】Vistaでは、ユーザ設定を上書き保存するとエラーが発生していました。

Wordインターフェース

  • CTRL + ALT + F9 を押と、キーボードショートカットが有効・無効に切り替わるようになりました。切り替えるたびに、反応音が鳴ります。CTRL + ALT + F9というショートカットが他の機能が与えられていても、その機能も有効です。
  • CTRL+ALT+↑ を押すと、「翻訳モード」でも現在のエントリの訂正ができるようになりました。
  • 【不具合の改善】終了しても、MS Officeのプログラムがメモリに残る場合がありました。
  • 初期設定では、翻訳歴基能が無効になっています。

Excelインターフェース

  • 【不具合の改善】メモリをエクセルファイルとして保存すると、「形式が間違っています」というエラーが発生していました。
  • 【不具合の改善】終了しても、MS Excelのプログラムがメモリに残る場合がありました。
  • 初期設定では、翻訳歴基能が無効になっています。

PowerPointインターフェース

  • 【不具合の改善】終了しても、MS PowerPointのプログラムがメモリに残る場合がありました。

バージョン1.4.2の変更点(2008/12/29リリース)

Felix バージョン 1.4.2 には、主にユーザの要求があった改善や新機能が含まれています。その他に、このバージョンではライブラリファイルのミスマッチを解消するための改善も含まれていますj。下記の新機能や改善を必要とする方に、バージョンアップをお勧めします。

Felix

  • 【新機能】ユーザ設定がプロフィールとして保存することができるようになりました。ユーザー設定の保存・取り込みをするには、[Felix] メニューから [ユーザ設定の取り込み・保存] を選択します。次のような設定が保存されます。
    • 翻訳メモリ(TM)ファイル
    • グロサリ(用語集)ファイル
    • ユーザ設定
    • ウィンドウの位置とサイズ
    • 文字の倍率

    プロフィールを取り込むとき、取り込まれていたTMや用語集が取り込まれます。

  • TMファイルとグロサリファイルに別々の拡張子になりました。初期設定では、Tmファイルには".ftm"という拡張子が、グロサリファイルには".fgloss"という拡張子が付けられるようになりました。旧".xml"拡張子のファイルもそのまま利用できます。
  • 【新機能】Felixのメモリウィンドウ・グロサリウィンドウの倍率を調整するためのダイアログがあります。「倍率の設定」ダイアログを表示するには、「表示」メニューから「倍率...」を選択します。
  • F6キーを押すと、マッチ表示・コンコーダンス(部分一致)表示の切替ができます。
  • 【不具合の改善】「起動時、前回使っていたメモリ・グロサリを取り込みます」が有効になっているときに起動すると、からのメモリが追加されました。
  • 数字の自動置換え機能では、全角数字も置き換えられます。
  • Felix起動時に、前回の文字の倍率が復元されます。

Wordインターフェイス

  • マイナーな改善

PowerPointインターフェイス

  • 【不具合の改善】Felixをインストールした後、初期設定ではツールバーが非表示になっていました。

バージョン1.4.1の変更点(2008/12/19 リリース)

Felix バージョン1.4.1は、いわゆるマイナーリリースです。新機能として、エラーログやエラー報告機能が利用可能になりました。エラーが発生した場合、エラー報告を送信していただくことで、そのエラーがより早く対応できます。

バージョン1.4の変更点 (2008/12/08 リリース)

Felix バージョン1.4は、メジャーリリースです。下記の新機能や改善を必要とする方に、バージョンアップをお勧めします。

Felix

  • 【不具合の改善】メモリのエントリや用語集のエントリを編集すると、編集前のエントリが残る場合がありました。
  • 【不具合の改善】メモリをエクセルファイルとして保存するとき、エラーが発生する場合がありました。
  • メモリ(TM)やグロサリ(用語集)を開くとき、統合するか、別のTMとして開くかを聞くダイアログが作成されました。
  • データ(一致など)の表示を一部新しくしました。
  • スクリプトのAPIを改善しました。スクリプトのAPIがパワーアップされています。 詳細は、付録A:Felix ソフトウェアとスクリプトを参照してください。
  • 【不具合の改善】用語登録の際、余計な空白文字を削除する機能を改善しました。

Wordインターフェイス

  • 【新機能】翻訳歴。詳細は、5.6 翻訳歴を参照してください。
  • 【不具合の改善】数字のみの文節が無視する際、コンマ(,)を含める文字列も数字として認識されます。

Excelインターフェイス

  • 【新機能】校正モード。詳細は、6.3 校正モードを参照してください。
  • 【新機能】翻訳歴。詳細は、6.5 翻訳歴を参照してください。
  • 【不具合の改善】ユーザ設定でUI言語を切り替えても変わらない場合がありました。
  • 【不具合の改善】数字のみの文節が無視する際、コンマ(,)を含める文字列も数字として認識されます。

PowerPointインターフェイス

  • 【不具合の改善】ユーザ設定でUI言語を切り替えても変わらない場合がありました。
  • 【不具合の改善】数字のみの文節が無視する際、コンマ(,)を含める文字列も数字として認識されます。

バージョン1.3.1の変更点

Felix バージョン1.3.1では、いくつかの不具合が改善されています。下記の不具合を経験している方に、バージョンアップをお勧めします。

Felix

  • 「起動時、前回使っていたメモリ/グロサリを取り込みます」という機能では、メモリ/グロサリのファイル数の上限をそれぞれ5個から10個に増えました。
  • 【不具合の改善】Felixウィンドウで「削除」をクリックしたとき、いつも最初のエントリが削除されていました。
  • 【不具合の改善】グロサリウィンドウで「編集」ダイアログにてエントリを編集しても効果がありませんでした。
  • 【不具合の改善】メモリ・グロサリを取り込んだとき、空のメモリ・グロサリも追加されていました。
  • 【不具合の改善】「ロック」されたメモリの取り込みができませんでした。

Wordインターフェイス

  • 【不具合の改善】全角英数+全角ピリオド(.)が選択されたとき、検索範囲の拡張ができませんでした。

バージョン1.3の変更点

Felixバージョン1.3はいわゆるマイナーリリースで、いくつかの不具合の改善や新機能が含まれています。

Felix

  • 用語検索の結果が参照カウント順に並べられるようになりました。(一番よく使われる用語が最初に出ます。)
  • メモリエントリを削除すると、それと同じ用語エントリがあればそれも削除されます。
  • 「登録」ダイアログは一回目しか表示されません。
  • 【不具合の改善】ファイル名に複数のピリオド(.)があった場合、ファイル名が正しく保存されませんでした。
  • 【不具合の改善】「ヘルプ」メニューの「登録」項目に不具合がありました。
  • 【不具合の改善】メモリ画面の背景色がユーザ設定を正しく反映しない場合がありました。
  • 【不具合の改善】訳文検索では、まれに訳文の代わりに原文が表示される場合がありました。
  • 【不具合の改善】FelixのTMがXMLとして不正な場合がありました。
  • 【不具合の改善】Memory Serves上のTMエントリを編集しようとするとエラーが出ました。
  • コマンドラインやドラッグ・ドロップにてMultiTermの用語集、TMX形式のTM、およびFelixの用語集が取り込めるようになりました。
  • MultiTermの用語集やTMX形式のTMがドラッグ・ドロップ操作にて取り込めるようになりました。
  • 初期設定では、「大文字と小文字を区別しない」と「用語検索の結果ナンバリングが1から始まる」という設定が有効になりました。
  • 【不具合の改善】起動時に翻訳メモリ ウィンドウの背景色の設定が反映されませんでした。
  • ダイアログ画面の文字が大きくて見やすくなりました。
  • 【不具合の改善】MultiTermバージョン5.5の用語集を読み込もうとするとエラーが出ました。

Wordインターフェイス

  • ピリオド(.)の後ろの空白文字を選択する設定が追加されました。
  • 「数字のみの文節を無視する」設定では、パーセント(%)やピリオド(.)が含まれる数字も無視されるようになりました。
  • 【不具合の改善】まれに、「翻訳モード」と「校正モード」との切替でエラーが出ました。
  • 【不具合の改善】全角英数に含まれる全角ピリオド(.)が文節の終わりと認識してしまっていました。
  • 【不具合の改善】複数の文書を同時に翻訳するときに、文節検索に不具合がありました。
  • ダイアログ画面の文字が大きくて見やすくなりました。
  • エラー処理の改善。

PowerPointインターフェイス

  • 「ユーザ設定」のダイアログが追加されました。
  • スライドの最後のテキストボックスを訳した後、「次のスライドに進むか、現在のスライドのトップに戻るか」という設定が追加されました。
  • 【セグメントルールの設定】ピリオド(.)の後ろの空白文字を選択する設定。
  • 【セグメントルールの設定】数字のみの文節を無視する。
  • 【セグメントルールの設定】全角文字の有為に応じて文節を無視する。
  • 【セグメントルールの設定】書式を無視する設定が細かく調整する。
  • 【セグメントルールの設定】文節終了マーカー(ピリオド、改行など)を指定する。
  • Shiftキーを押しながら用語を取得すると、小文字で書式なしとして取得されます。

Excelインターフェイス

  • 「ユーザ設定」のダイアログが追加されました。
  • 【セグメントルールの設定】数字のみの文節を無視する。
  • 【セグメントルールの設定】全角文字の有為に応じて文節を無視する。

バージョン1.2の変更点

Felixバージョン1.2はいわゆるメジャーリリースでいくつかの大きな改善や新機能が含まれています。

Felix

PowerPointインターフェイス

Excelインターフェイス

  • Felixのツールバーが追加されました。

バージョン1.1.6の変更点

Felix

バージョン1.1.6はマイナーリースで、検索機能の不具合を修正するために公開されています。このリリースには、新機能が含まれていません。

バージョン1.1.5の変更点

Felixバージョン1.1.5マイナーリリースで、いくつかの改善は不具合の修正が含まれています。このバージョンの主な改善点は下記のとおりです。

Felix

  • TMX形式のメモリの不具合を修正。
  • メインウィンドウはグロサリウィンドウにTM・用語集ファイルをドラッグすると、そのTM・用語集が読み込まれます。

PowerPointインターフェイス

  • 不具合の修正:PowerPoint2007ではいくつかのオブジェクトの種類が正しく認識されていませんでした。
  • PowerPoint2003以下では、ツールバーは前回の位置に戻るようになりました。

Wordインターフェイス

  • Word2003以下では、ツールバーは前回の位置に戻るようになりました。

バージョン1.1の変更点

Felixバージョン1.1マイナーリリースで、いくつかの改善は不具合の修正が含まれています。このバージョンの主な改善点は下記のとおりです。

Felix

  • メモリ画面の表示が一新されました。
  • 表示のひながたが外部ファイルとなりました。
  • 検索機能に自動選択機能が追加されました。
  • グロサリ一致採点のアルゴリズムの選択が全自動となりました。
  • 用語(グロサリ エントリ)登録のダイアログでは、余計な空白文字が削除されます。
  • 不具合の修正:ファジーマーキングの表示・非表示の切替。
  • 不具合の修正:メモリウィンドウのツールチップがグロサリウィンドウの文字列になっていました。
  • 不具合の修正:UI言語を切り替えても、ツールチップ言語が変わらない場合がありました。
  • UIの統一。

Wordインターフェイス

  • 不具合の修正:検索の取り消しがうまく動作しない場合がありました。

バージョン1.0の変更点

Felixは、TransAssistの新バージョンです。これまでのTransAssistの特長を継承し、さらにいくつかの機能が追加され、より充実したツールになりました。Felixなら、パワフルな翻訳メモリシステムを翻訳ワークフローに簡単に取り入れることができます。Felixの主な改善点は下記のとおりです。

Felix

  • 以前に比べて検索のスピードがアップしました。数十万ものエントリを含む翻訳メモリも、軽快に使うことができます。
  • 翻訳メモリウィンドウでは、クエリー(照会)、原文、訳文の色を指定できます。
    詳細については「3.2.11 ユーザ設定を定義する」の「表示」タブを参照してください。
  • グロサリマッチの場合と同様に、すべての訳文マッチを一覧表示
    詳細については、「 3.2.11 ユーザー設定を定義する」の表示 タブを参照してください。
  • グロサリマッチのファジーマッチング
    詳細については、「3.2.11 ユーザー設定を定義する」のグロサリタブを参照してください。
  • グロサリマッチとメモリマッチにマッチングアルゴリズムを選択
    詳細については、「3.2.11 ユーザー設定を定義する」のアルゴリズム タブを参照してください。
  • メモリとグロサリの検索に、“全角と半角を区別しない“、“大文字と小文字を区別しない”、“ひらがなとカタカナを区別しない”のオプションを指定
    詳細については、「3.2.11 ユーザー設定を定義する」の メモリタブと グロサリタブを参照してください。

Wordインターフェイス

  • Microsoft Word 用インターフェイスが一新されました。Wordインターフェイスを刷新し、新たに“訳文”モードと“校正”モードを追加しました(好みに応じて、従来のインターフェイスも選択可能)。 このインターフェイスにはツールバーも表示されます。
    詳細については、「 5. WordでFelixを使用する」を参照してください。
  • 数字のみのセグメントを自動的にスキップするオプション。数字の表などがあるファイルを翻訳するとき便利です。
  • プレーンテキストのセグメントを検索し表示するには、キーボードのShiftキーを押しながら任意のショートカットキーを押します(グロサリマッチの場合は、Shiftキーを押さずに小文字だけで検索することもできます)。
  • 表示したい書式レベルを指定します(たとえば、フォントスタイルを使用する場合、Font Faceプロパティは設定しません)。
    詳細については、「 5.1 WordでFelixを使用する — はじめに」を参照してください。
  • どの文字を文の「終了記号(終了符)」にするかを選択します。

Excelインターフェイス

  • キーボード ショートカット
  • 現在選択している原文、ワークシート、またはワークブックを自動翻訳します(完全一致の文は自動翻訳されます)。

PowerPointインターフェイス

  • テキストボックスは、画面に表示されている順に翻訳されます。

PowerPoint 2007を使用時に起きる重大なエラーやTMXファイル解析時の問題など、以前にあったいくつかのバグは修正済みです。

前に戻る | 次へ進む